В ядре Linux устранили уязвимость, появившуюся в 2009 году

НОВОСТИ
2017-03-17 14:37:11
0
2.6K

Linux-OS-Logo_1920x1080_6052

Около месяца назад в ядре Linux была обнаружена проблема CVE-2017-6074, которая позволяла повысить привилегии пользователя, он была обнаружена почти во всех популярных дистрибутивах, включая Debian и Ubuntu, парадокс в том, что проблема существовала аж с 2005 года.

И вот, совсем недавно, исследователь Александр Попов сообщил об обнаружении ещё одного бага, который получил название CVE-2017-2636. Александр уточняет, что данная проблема появилась в ядре в 2009 году, она позволяет ввести в состояние гонки драйвер n_hdlc, что в свою очередь выдаёт ошибку double-free. И в итоге атакующий получает неограниченные привилегии, по десятибальной шкале эта уязвимость получила 7,8 баллов.

"Уявзимость не новая, ей далеко не первый год, из-за этого она находится почти на всех домашних компьютерах и серверах, работающих на Linux. Для атаки необходимы права обычного пользователя, более того уязвимость не имеет специальных требований к железу".

Данная проблема задела многие известные дистрибутивы такие как, Fedora, Ubuntu, Debian. Патч с исправлением данной ошибки уже выпустили, но есть и альтернативные способы решения. например можно добавить правило /etc/modprobe.d/ .

0
2.6K
Написать комментарий

Добавить комментарий